New speakers and new installation but no sub!!!!frustration.. - Honda Ridgeline Owners Club Forums
     Honda Ridgeline Owners Club Forums
Go Back   Honda Ridgeline Owners Club Forums > Honda Ridgeline Accessories, Care and Mods > Mobile Electronics


RidgelineOwnersClub.com is the premier Honda Ridgeline Forum on the internet. Registered Users do not see the above ads.
Notices

Reply
 
Thread Tools Display Modes
Old 12-26-2012, 10:43 AM   #1
sparky567
ROC Rank: Sophomore
2007 RTL
White / Beige
 
sparky567's Avatar
 
Join Date: Jul 2009
Location: Portland, Oregon
Posts: 167
Unhappy New speakers and new installation but no sub!!!!frustration..

Originally Posted by sparky567 (at the wrong location)
Well so much for building a box for a sub…

Santa brought me Pioneer speakers a set of these http://www.pioneerelectronics.com/PU...ries/TS-A1604C

Hopefully the tweets will fit and a set of these http://www.pioneerelectronics.com/PU...ries/TS-A1674Rfor the rear.

The sales person was trying to sell my wife a HU but "not this time" she said to him but also got a 20 sq.ft roll of Dynamat, I mentioned my ideas and the components that would be needed and maybe save a few bucks. She got the speakers from Car Toys stereo/car installers (Colorado, Texas,Oregon and Washington), and you know what their prices can be.
She even forked out the money to have these speakers installed (prepaid), who I’m I to argue, been married to her 30 years this summer… need I say more.
I still want to get rid of the factory one way or an other....

All this time I was expirementing with building a box for my yet to come sub,
I just wonder if I should keep building the sub box, and maybe make extra ones, because I have enough material to do more...

What do you think?
Any comments?
Any opinions ?
sparky567 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 12-26-2012, 01:00 PM   #2
Bigscrap
ROC Rank: Freshman
2013 SPORT
Crystal Black Pearl
 
Bigscrap's Avatar
 
Join Date: Nov 2012
Location: Louisville, KY
Posts: 65
Re: New speakers and new installation but no sub!!!!frustration..

What's the overall idea here? Whether you still need a sub after new speakers and tweets? I would still put a sub in if you don't have a factory one to begin with. I just installed front and rear speakers along with tweeters and dynamat on my 2013 Sport and it's an insane improvement. Sport doesn't come with a factory sub, and although I did get a small amount of bass from the new speakers, I still plan on installing a 250W Bazooka Tube next week cause it needs more imo. I also have a new HU to install which will push more power to my speakers as well.
Bigscrap is offline   Reply With Quote Quick reply to this message
Old 12-26-2012, 03:54 PM   #3
sparky567
ROC Rank: Sophomore
2007 RTL
White / Beige
 
sparky567's Avatar
 
Join Date: Jul 2009
Location: Portland, Oregon
Posts: 167
Re: New speakers and new installation but no sub!!!!frustration..

I need to bring the truck in for "them" to do the work, and wait and see. I still plan to replace the stock subwoofer, eventualy. These guys are going to be tearing the truck apart to put in the speakers, maybe if I have the right equipment the can instlall my subwoofer box that I/m presently building.

BigScrap: What HU did you get to the factory one in your new Sport?
sparky567 is offline   Reply With Quote Quick reply to this message
Old 12-26-2012, 05:28 PM   #4
Bigscrap
ROC Rank: Freshman
2013 SPORT
Crystal Black Pearl
 
Bigscrap's Avatar
 
Join Date: Nov 2012
Location: Louisville, KY
Posts: 65
Re: New speakers and new installation but no sub!!!!frustration..

I'm putting a http://www.pioneerelectronics.com/PU...rs/AVH-P2400BT in when I get the time next week. Was on sale at Crutchfield for 250$ I believe with the needed accessories.

I'd see if you can get your money back on the install and just do it yourself. It's super easy especially with the threads on here to guide you. Save ya enough to buy rear speakers and a sub probably ha. The only part that takes time is installing the dynamat, speakers take like 2 minutes.

Last edited by Bigscrap; 12-26-2012 at 05:32 PM.
Bigscrap is offline   Reply With Quote Quick reply to this message
Old 12-26-2012, 06:02 PM   #5
sparky567
ROC Rank: Sophomore
2007 RTL
White / Beige
 
sparky567's Avatar
 
Join Date: Jul 2009
Location: Portland, Oregon
Posts: 167
Re: New speakers and new installation but no sub!!!!frustration..

you know I don't upset the wife, she paid for it and she does want me to see the bill! I dont get it even after 30 years. But I'm exploring a different avenue.

I read some of you pass post regarding Bazooka, and looked up the dimensions, they are both the same size H 8" L 18 1/2 and 6 3/4, did you end up getting one?
sparky567 is offline   Reply With Quote Quick reply to this message
Old 12-26-2012, 06:11 PM   #6
Bigscrap
ROC Rank: Freshman
2013 SPORT
Crystal Black Pearl
 
Bigscrap's Avatar
 
Join Date: Nov 2012
Location: Louisville, KY
Posts: 65
Re: New speakers and new installation but no sub!!!!frustration..

Yep, I got the 250W Bazooka. Same size as the 100W one. They should fit under the rear drivers side seat once they are taken out. I need the space directly under the seats for cargo or I would put a full box in.
Bigscrap is offline   Reply With Quote Quick reply to this message
Old 12-26-2012, 06:18 PM   #7
sparky567
ROC Rank: Sophomore
2007 RTL
White / Beige
 
sparky567's Avatar
 
Join Date: Jul 2009
Location: Portland, Oregon
Posts: 167
Re: New speakers and new installation but no sub!!!!frustration..

I love my cargo space that's why I wanted to build my own "ed box" and put it behind the seat like some other guys did.
Did you find a good deal for your 250watt ?
sparky567 is offline   Reply With Quote Quick reply to this message
Old 12-26-2012, 06:33 PM   #8
Bigscrap
ROC Rank: Freshman
2013 SPORT
Crystal Black Pearl
 
Bigscrap's Avatar
 
Join Date: Nov 2012
Location: Louisville, KY
Posts: 65
Re: New speakers and new installation but no sub!!!!frustration..

200$ from Sonic Elextronix I believe. Had to buy an amp kit and the volume control from Amazon separate.
Bigscrap is offline   Reply With Quote Quick reply to this message
Old 12-26-2012, 08:03 PM   #9
laserguy
ROC Rank: Freshman
2006 RTL
Other
 
laserguy's Avatar
 
Join Date: Jul 2009
Location: N.Cali
Posts: 5,412
Re: New speakers and new installation but no sub!!!!frustration..

Nice entry level components your wife got, convenient for easy installation without external xovers.
I doubt the tweeters will fit in the factory location unless you can take them apart. You may want to check this
http://www.ridgelineownersclub.com/f...ad.php?t=46873
and tell them to install them like on the link with either option, sail panel or pillars. The sound will be much better if angled towards the center of seats.
yes speaker level input equals internal LOC.
Both the kenwood and new alpine I have don't need a LOC, kenwood has gotten better on their amps lately but not quite close to alpine quality, *including the internal LOC.*
The only benefit of that combo is the amp wiring kit, but that is not a good quality, it's cca and not OFC pure copper wire. *And I think the sub is like $70 from amazon right now. It's up to you.


Al
laserguy is offline   Reply With Quote Quick reply to this message
Old 12-26-2012, 08:27 PM   #10
sparky567
ROC Rank: Sophomore
2007 RTL
White / Beige
 
sparky567's Avatar
 
Join Date: Jul 2009
Location: Portland, Oregon
Posts: 167
Re: New speakers and new installation but no sub!!!!frustration..

These entry level.. wil be the only level, these are going in and never being replaced,
and BTW the tweets are already apart in the box, I guess I could put them in the sail panel or pillars, and the tweeter come in different mounting cup if you want to call it that.

How long would it take to do an istall for an "ed box" and amp, removing part of the seat that needs to removed running the wires to the battery and maybe put some dampenig material behind the box ?
sparky567 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Honda Ridgeline Owners Club Forums > Honda Ridgeline Accessories, Care and Mods > Mobile Electronics

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Honda Ridgeline Owners Club Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Navi frustration emek69 First Generation (2006-present) 21 03-11-2013 09:24 AM
Radio code frustration mntentman Mobile Electronics 12 03-05-2012 10:33 PM
Frustration with dealers... timfromohio Shoppin' and Test Drivin' 7 03-14-2011 03:58 PM
Rattles, squeeks and frustration! WadeHampton Problems & Issues 41 11-23-2010 12:10 PM
New Speakers Sony XS-GTX1640 6-1/2" Full Range 4-Way Speakers - Pair Jiggy Mobile Electronics 1 02-23-2009 01:44 PM


All times are GMT -6. The time now is 10:32 PM.



Views and opinions expressed on this forum are not necessarily those held by Autoforums, Inc. or forum management.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.