Honda Ridgeline Owners Club Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
77 Posts
Discussion Starter #1
I have a 2008 RTL with 110000 miles. This has been happening for some time now.

Sometimes when I start the truck the radio is dead. the Navi will work but no radio, XM, CD or AUX. Power on-off button does noting, press the button on the navi to display the radio.. noting the small display below the navi... nothing (although the back-light is on)
Shut down the truck and re-start.. all works fine.. Does this 2-3 times per week. doesn't matter if it's cold or warm or hot. It does it if left overnight or just a short off-on cycle. No rhyme or reason.:act002:

flash forward... Dealer replaces radio head unit under Honda care.

Does the same thing.. but now has an additional intermittent problem.. Sometimes the radio and xm and aux works but the CD doesn't.. the CD button on the touch screen is gone..

same fix.. restart the truck everything comes back.

Dealer is going to Honda for ideas.. waiting for Honda to get back to them.

Anyone have a clue?

BTW. Battery was changed 1 year ago.
 

·
Registered
Joined
·
77 Posts
Discussion Starter #2
OMG I'm the only person that has this problem!!! Honda has no idea. They are now talking to Alpine.
 

·
Super Moderator
2008 Ridgeline RTS in Billet Silver Metallic
Joined
·
22,778 Posts
Sorry. No clue.
 

·
Registered
Joined
·
651 Posts
Well, I don't know speciffically either.
But, my troubleshooting experience tells me that if a malfunctioning part is replaced twice by a known good parts and the same problem recures the issue is likely not the replaced part.
In your case, since it seems to me pretty unlikely that you've gotten 3 bad radios that are bad in the same way I'd be looking elsewhere. So, if it were me, my next area of interest would be the wiring harnesses to the radio. I'd be looking for damaged wires, worn insulation, cracked or ill fitting plugs, etc. I might also bench test one of the "bad" radios by hooking up just power and then speakers, etc to see if I could mimic the fault.
Anyway, those are some of my thoughts, IDK if they help you or not. In any case, good luck getting the problem resolved.
 

·
Registered
Joined
·
13 Posts
Huh. I posted a thread about my stereo not turning off. I have an 08 rt with 102k on it. The honda dealership still thinks its the stereo, and pulled it out to send it in for repairs once again.
 

·
Registered
Joined
·
77 Posts
Discussion Starter #6
update.
After talking with Honda and Alpine.. the dealer pulled the cd player and sent it back for repair.
 
1 - 6 of 6 Posts
Top