Honda Ridgeline Owners Club Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I recently purchase a used 2009 Ridgeline. The multi information display does't appear to be working. I first noticed it when I tried to reset the trip A mileage and it just changes to the next screen. It appears to display every thing for the trip A but will not reset. It doesn't even move to trip B screen. I have changed the select and trip reset switch but that didn't make a difference. I am wondering if it is in the display itself. I can move to several screens with trip A but can't move to trip B or reset trip A. Any suggestion from someone who may have experienced the same thing? Thanks
 

·
Premium Member
2009 Ridgeline RTL (with nav) in Bali Blue Pearl
Joined
·
2,379 Posts
I have not had that problem with my 09 RTL (with nav), but what happens when you hold down the Set/Reset Button for an extended period of time?
398959
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
mine doesn't have nav, but when I hold down the button for along time, it changes pages as soon as I push the button but then nothing happens. I have held it for up to a minute and nothing happens.
 

·
Premium Member
2009 Ridgeline RTL (with nav) in Bali Blue Pearl
Joined
·
2,379 Posts
mine doesn't have nav, but when I hold down the button for along time, it changes pages as soon as I push the button but then nothing happens. I have held it for up to a minute and nothing happens.
Okay, that means you do not have the "multi-information display" but the information display (there's a difference).
398960

I have never read of anyone having this problem, so all I can do is say follow the instructions in your owner's manual (pages 76-81) and if that does not work, take it to your local Honda dealer.
398961
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
I guess I'll have to take it to my dealer, because I have the button display in the picture you sent. According to my manual, I should have the progression as shown in the chart, but don't. Thanks for you help.
 

·
Registered
Joined
·
1 Posts
I guess I'll have to take it to my dealer, because I have the button display in the picture you sent. According to my manual, I should have the progression as shown in the chart, but don't. Thanks for you help.
Did you end up figuring out what the issue was? I'm having the same problem with my multi-information display button on my 2012 Ridgeline.
 
1 - 6 of 6 Posts
Top