Honda Ridgeline Owners Club Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1 (Edited)
Hi all!

I thought I would give the forums a shot as I have never tried them before. My name is Jordan, I drive an 06' RTL, just shy of 150k miles, and I am experiencing a few issues that I am hoping someone has experience with and can give me an idea of how to diagnose/repair.

The first is my AC. I am down at the lake right now and will be out here for a couple more days, but when I drive home it would be nice to have being summer. We were driving into town, worked fine, then I noticed on the way back it was no longer blowing any air at all. I tried turning it off and turning it up, nothing. It sounds like the compressor is not kicking on or off. Checked all fuses, seem to be fine. Tested battery reading at 12.68, 14.22 when running. While using my multimeter to test battery, AC turned on for about 5seconds then went back off. This dropped the readings to 14.17.

The second issue I am starting to experience or rather have been noticing for awhile is that I will periodically have random lights display for a brief time then turn back off after a short time of being on. These lights have included the VSA, TPMS, and my air bag light. When the VSA light comes on so does the caution light like when you would turn it off. I have had my check engine light on for a long time now for my catalytic converter, not that I really plan on replacing anytime soon, but after I finished pulling fuses and checking them that light went off which I thought was odd.

Lastly, from time to time the backlight on my deck (radio) will decide it wants to come on which most of the time it just stays off. I know a lot of people have had issues with that, is there any fix for it other than buying a new one? As it comes on periodically it seems to me it was just wired poorly.

Thank you all for taking the time to answer my questions!

Jordan
 

·
Registered
Joined
·
5,620 Posts
First suspect in all of these cases is a failing battery. It doesn't need to be dead, just old & heading south. How old is your battery? (regardless of how it tested)
If it's 4 years or older, there's a REALLY good chance that your problems all go away when you put in a new battery.

Next, consider there are A/C relays that go bad.... you'll find multiple threads that address this. This can be checked easily by swapping out with another similar relay that operates something else (I don't remember what, but you can read about it).

You will find that if you use the pull down search box on the blue stripe above, you will quickly locate many threads with lots of posts discussing the A/C fail issue; and there are multiple culprits, but far & away the most common is the A/C relay. Try searching "A/C relay"

Check it out.... if you have time at the lake, you'll be able to get real smart real quick wrt A/C issues on the RL. I think you'll find there are lots of good information sources on this forum, and between the actual members responding & the fantastic library of info you can search, you'll be a happy camper sooner or later. Good Luck fixing your A/C ! !

:act030:
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
Battery was good, fuses/relay good, blower motor had gone bad. Ordered a new one from autozone, will be here in a few hours. I have already took out the old one so should be a plug and play kind of fix. Thanks for the help.
 

·
Registered
Joined
·
2,533 Posts
Based on your other post, I'm guessing the blower motor was still good?
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
Yes, the mechanic guessed wrong unfortunately. Fortunately, autozone let me return the new blower.
 
1 - 5 of 5 Posts
Top