Honda Ridgeline Owners Club Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
281 Posts
Discussion Starter #1
06 RT Ridge. I’m ready to junk the whole truck lol. Changed out the stock radio to Pioneer AVH-P4400BH. From the get go the AM/FM reception has been the shits. I re checked the wires to the amplified antenna and everything is good. I started thinking the antenna booster was crap. Went to auto store picked up a aftermarket fender antenna, plugged it in and grounded it with a wire to battery. Held antenna up in the air as high as I could and still no AM at all and spotty at best FM. I’m now thinking I got a shitty Pioneer HU receiver. I’m at the end of my rope. Thinking of getting a new Sony HU.
 

·
Registered
Joined
·
423 Posts
I remember my '06 with stock radio had pretty awful FM reception, but not nearly as bad as you are describing it. I would guess the antenna connection on your Pioneer has a bad connection or the truck antenna had a short somewhere. You could test it with an ohm meter to find out for sure.
 

·
Premium Member
2104 Honda Ridgeline SE
Joined
·
1,804 Posts
Have you connected the blue antenna wire to the red 12v switched wire? This is a common problem with new HU install. I went and changed my antenna because the stock antenna isn't great unless matched with the stock radio. Do a search of this forum for antenna or radio reception or look here...

 

·
Premium Member
2010 RT - Bali Blue
Joined
·
4,146 Posts
If nothing works, swap out the headunit. I have not listed to Am/FM channels in a decade, so cant help you with radio stations.
 
1 - 4 of 4 Posts
Top