Honda Ridgeline Owners Club Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
driving on Highway truck shuddered and lost power all system lights came on and info center messaged systems were not working properly one message at a time, I pulled over due to lack of power to accelerate shut truck off and tried a restart to see if malfunctions would reset but they did not, had power back so i could at least get home which was about 3 miles away. that was on saturday on sunday found a dealer service department open thought I would try to get it there and on the way all systems cleared . went anyway but they said they have not heard of the problem and bring back if it happens again, I will call Honda Corp tomorrow and talk to a tech if possible.
 

·
Registered
2007 Nimbus Grey Metallic RTL
Joined
·
10,048 Posts
What year RL is this - 2nd gen or 1st gen? If it's brand new, obviously take it to a dealership and have them do a FULL lookover of the electrical system. If it's older and out of warranty, you could have a failing battery or alternator. Could also be something as simple as a bad ground or as serious as a failing PCM/ECU.
 

·
Registered
Joined
·
1 Posts
Hi - same thing happened to our 2016 Ridgeline that has 700 miles. Took it in and the wheel sensor was replaced only to get in the car to drive off lot (after having it for 5 days) to have it happen again. Left it again to be fixed. Today was told that water is funneling off the sunroof when it gets wet and channels into the sensors somehow (didn't totally understand this). Hondo is aware of the problem even though no technical bulletins have been issued to the dealerships. The part for the fix is coming direct from the manufacturer that was hired to come up with the fix. The parts have yet to be distributed to the vendors that supply the parts to the dealership service departments. What a mess! Looks like a recall is in the future for all owners of this vehicle.
 

·
Registered
Joined
·
128 Posts
Now that is disturbing. Would have to follow that routing. I have seen photos on the forum that show the drain hose that floods the carpet. Anyone on here completely familiar with the routing from the roof to the floor?
 

·
Registered
2007 Nimbus Grey Metallic RTL
Joined
·
10,048 Posts
Hi - same thing happened to our 2016 Ridgeline that has 700 miles. Took it in and the wheel sensor was replaced only to get in the car to drive off lot (after having it for 5 days) to have it happen again. Left it again to be fixed. Today was told that water is funneling off the sunroof when it gets wet and channels into the sensors somehow (didn't totally understand this). Hondo is aware of the problem even though no technical bulletins have been issued to the dealerships. The part for the fix is coming direct from the manufacturer that was hired to come up with the fix. The parts have yet to be distributed to the vendors that supply the parts to the dealership service departments. What a mess! Looks like a recall is in the future for all owners of this vehicle.
That's truly awful to deal with on a brand new vehicle (for the record, it's a 2017 model). Nonetheless, unless that water is funneling onto a very important electrical component, I don't understand how it could short out the entire electrical system. Methinks there's a larger problem than what was stated and the dealership simply hasn't found out the root cause yet. I hope it gets resolved.
 

·
Registered
Joined
·
55 Posts
This has been an ongoing problem with the new Piolt's,new civic's, and new Ridgelines !
 
1 - 7 of 7 Posts
Top