Honda Ridgeline Owners Club Forums banner
1 - 2 of 2 Posts

· Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I picked up my 2017 RTL-E Saturday and absolutely love it. Great ride, everything works..everything I hoped it would be.

One little item: on the display that rotates between a compass/mpg/tire pressure, etc., there's a thin horizontal white line in the middle of the display. Sometimes it blinks, sometimes it disappears for a while. It doesn't affect function but obviously shouldn't be there. Thoughts?

(Incidentally, I have been waiting on my RTL-E since September-these things are almost impossible to get. Dealers won't trade them to other dealers and when a dealer gets one, invariably it's already pre-sold.)
 

· Registered
Joined
·
286 Posts
That white line unfortunately sounds like a display problem. You may need to take it to the dealer and have them determine the problem. If the display has a flakey wiring for a row of pixels it could behave this way. I'd think they would have to do a swap if this is the case.

I hope it is something simpler! Keep us updated.

I agree with the RTL-E being a hard item to find. I travelled 120 miles to an adjacent state to get mine in the color I wanted. I placed a deposit prior to it being built! In the few days it was waiting on the dealer lot they had several people make offers to buy it out from under us! Fortunately, the dealer stood behind the deal and we were very glad to drive it out of their lot!

Paul.
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top