Honda Ridgeline Owners Club Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Hello anyone!

My 2006 Honda Ridgeline is feeling a little down. The Check Engine light has been coming on (intermittently)...techs say its the emissions. The TPMS light has been coming on (also intermittently), and they can't find a faulty sensor. Now, the VTM-4 light is coming on (yep, you guessed it, intermittently), and she drives a little rough. With only 413,000 miles, I was hoping she would last longer. Any ideas if I am looking at minor or major work? Any and all input is appreciated!
 

·
Registered
Joined
·
21 Posts
I was experiencing the following electrical issues on my 2006 RTL with 240,000 miles : VSA, VTM, ABS, Brake, Exclamation, and intermit TPMS lights on (check engine light never came on though). After much troubleshooting and replacing parts, my issue was a corroded engine ground cable connection. I accidentally broke off the ground cable engine bolt, engine ground cable B #5 from the diagram image. I got the cable removed to clean the cable end and mounted it to the engine removal loop for a temporary location (had to drill a small hole and then bolted it to the loop). I started the engine and all the lights remained on, the good news is all my electrical issue lights all went off after driving it out of the driveway. Later I was able to replace the broken bolt from underneath the engine when I changed my oil, I also replaced the negative battery cable harness with a new OEM one, all lights remained off. Hope this helps. There's also a lot of troubleshooting on this site that has been done regarding this issue, good luck.
 

Attachments

1 - 4 of 4 Posts
Top