Honda Ridgeline Owners Club Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
My Ridgeline battery went dead today a few hours after driving it. It only has 1000 miles on it. I jump started it and took it to the dealer and it all checked out fine.

Any one else have this problem?

Does it need an upgraded battery?

I must have left the key on or a door open too long????

Post your ideas and experiences here.....
 

·
Registered
Joined
·
1,648 Posts
Who installed your fog lamps?

Could have been a loose ground connection at the battery. Dealer might have tightened it up when they checked the charging system.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #4
The dealer installed the fog lamps. The negative battery terminal seemed to be tight at the battery when I charged it a bit with a charger. That does seem to be a likely scenario.
 

·
Registered
Joined
·
112 Posts
I think the auto shut off will not turn the dome lights off if you have turned them on. The Dealer told me something like that- I think they had a problem with some one else running their battery down.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #7 (Edited)
I think I left the key in the on position with the door open for an hour.
My old truck or my Acura or old Hondas would not have gone dead.
It was hot so the radiator fan ran for a while too.

Is it normal for the battery to go dead under these situations?

How about using the radio all day while I work with the engine off?
Thanks for the tips and help...
Clay
 
1 - 7 of 7 Posts
Top