Honda Ridgeline Owners Club Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I have an 2006 RT with 102k miles and the rectangular odometer display flashes on and off. This started last winter. It was a random flash so I thought it might just be loose. When Summer got here it quit. It didn't do it at all this Summer! I live in Albuquerque so it's starting to get cold and it has started flashing again. It only seems to flash when it's colder than 60 degrees.
 

·
Registered
Joined
·
1,350 Posts
It is my understanding that there is a gauge control module. Why this would happen when it gets cold? Perhaps a bad solder joint someplace or just a bad module. Electronics don't like hot and cold.

There is a Honda procedure for resetting the module, maybe somebody can dig it up and post it. Otherwise you may need a part

look here for more:

http://www.ridgelineownersclub.com/forums/gtsearch.php?cx=partner-pub-7865546952023728:5yck7ww1tx0&cof=FORID:11&ie=UTF-8&q=gauge+control+module&sa=Search&siteurl=www.ridgelineownersclub.com/forums/index.php&ref=&ss=6384j2963072j20
 

·
Administrator
Joined
·
16,016 Posts
Gauge control module = instrument cluster.

Use the Google Custom Search box at the top of this page and search for "flashing odometer" or "blinking" odometer. You'll see others with this issue. The solution seems to range from re-seating the connectors on the back of the module (cluster) to repairing the module to replacing it.
 
1 - 4 of 4 Posts
Top