Honda Ridgeline Owners Club Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hi everyone! I've been watching this forum for about a year or so after I bought my RL. You've so far helped me with all my problems but one. So here's the low down.

It all started with the driver side window control system. The 4 switches that control the windows in the truck don't work.. After I swapped it with a new one. it worked for I think 4 days now it doesn't work. The mirror controls work, the rear window control works, the door lock only works when I sit in the seat and the truck is on. Otherwise nothing.

Now for problem two.... The gauges on the instrument cluster shake when I start the truck. I changed the two relays that the one thread talked about, the Starter cut out and power window relays. Swapped them withe new ones. Still shaking... Anyone have an idea?
 

·
Registered
Joined
·
5,620 Posts
'Suggest you search some threads on here that talk to similar problems. 'Seems to me that either the door lock actuator in driver's door or master window controller in driver's door has been reported to have various "side-effects" when they go bad.
Also, you said you "replaced it" and things were good for a short while. WHAT did you replace, and have you considered taking it back to get another one (of whatever it was). It's entirely possible you replaced the right thing but got a bad replacement???? Just a thought.

If you can't narrow down via search here, I'd suggest you take to a good auto electric shop & describe your problem.... let them give you a quote to troubleshoot & diagnose.

Lastly, is there any chance you've got an aftermarket tow hitch harness installed, or other aftermarket electronics (like radio head unit, back-up camera, tailgate lock, etc.) that have been "patched in" to your stock electrical system? If so, consider those as possible trouble makers, especially if they were not installed by professionals.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
Battery was replaced, all fuses check and replaced as needed, relay replaced with new, Master door switch replaced with new Honda part. Still same issue... Please any other ideas ???? :act060:
 
1 - 6 of 6 Posts
Top