Honda Ridgeline Owners Club Forums banner
1 - 9 of 9 Posts

· Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
Well I have had the 06 RT for 5 days now, and already need to buy a new radio, and now the fan on the heater/AC system didn't come on this morning on the way to work. It actually did kick on about 25 minutes into my drive, but at that point it wasn't really worth it.

Anyone else have this issue?
 

· Registered
Joined
·
173 Posts
How cold is it where you are and was your climate control on Auto ??? In the Northeast when it is below zero, it takes my truck 10 to 20 minutes before the fan starts due to it was waiting for engine heat to get up to temperature.

that is why I leave in in manual mode, defrost and fan on high so when I use my car starter at least the windshield gradually warms up....
 

· Registered
Joined
·
6 Posts
Discussion Starter · #6 ·
Yeah I went out during lunch to check out the automatic versus manual setting, I don't see either anywhere. Maybe I am just missing it completely. I haven't had time to look at the manual, but I will this evening.
 

· Super Moderator
2008 Ridgeline RTS in Billet Silver Metallic
Joined
·
24,671 Posts
RT does not have climate control.

RT hvac diagnostic test:





 

· Registered
Joined
·
2,446 Posts
I think I will try installing a new resistor. I can get a new BWD Intermotor (made by Federal Mogul) at Advance Auto for $37.79. I get 30% off by ordering online and using the TRT30 discount code. I've been using BWD Intermotor electrical parts for years without incident.
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top