Honda Ridgeline Owners Club Forums banner

1 - 14 of 14 Posts

·
Registered
Joined
·
198 Posts
Discussion Starter #1
Around 1.5 - 2 grand when cruising I’m getting a jutter that makes my RPMs jitter up and down quickly. Sometime sit feels as if it’s starving for gas....like a partially clogged fuel filter. Any ideas?

2017 RL Sport AWD. 58k miles


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
1,170 Posts
Probably the fuel injectors sticking. Next up will be the emissions errors. Estimates out of warranty appear to be around $1500 with Honda maybe helping maybe not it appears.

Steve
 

·
Registered
Joined
·
14 Posts
I highly doubt its your fuel injectors. I would bet on TSB 17-025 and TSB17-026. Everyone jumps on the fuel injector bus like its bringing you to the "pot of gold". Take a look at the pinned conversation at the top of the board. I believe its the third conversation down. It has lots of info about these 2 service issues.
 

·
Registered
Joined
·
100 Posts
Around 1.5 - 2 grand when cruising I’m getting a jutter that makes my RPMs jitter up and down quickly. Sometime sit feels as if it’s starving for gas....like a partially clogged fuel filter. Any ideas?

2017 RL Sport AWD. 58k miles


Sent from my iPhone using Tapatalk
Any resolution? I am experiencing the same issue with my 2017 RTL-E. I first noticed it around 65K miles, and the odometer is now close to 72K. Mine occurs mostly around 45 mph and going up a slight incline. I have a service appointment later this week to have it checked out and have already told them to start with TSBs 17-025 and 17-026. If applicable, the service bulletins mention that these TSBs will be covered under an 8/80 warranty. Honda claims the transmission is not damaged by this judder but rather deteriorated transmission fluid. I had my fluid serviced around 40K and do not do any extreme driving or towing of any kind. I should know something by Friday.
 

·
Registered
Joined
·
198 Posts
Discussion Starter #7
Had it in today. They said the tech was able to duplicate it on a test drive and they updated the engine computer or whatever. . I didn’t ask how or what. We’ll see


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
198 Posts
Discussion Starter #9
Seems to be running better. Few hundred miles since the updated computer. No issues


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
14 Posts
Hopefully just a pressure switch or solenoid. I wonder if the tech did something wrong. Whatever you find out, please report back.
 

·
Registered
Joined
·
198 Posts
Discussion Starter #13
Verdict after a visit to the dealer today - Getting a new tranny!


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
198 Posts
Discussion Starter #14
Now the question is, will I be getting the same transmission or is there a new one being used in the 2018 and 2019 models?


Sent from my iPhone using Tapatalk
 
1 - 14 of 14 Posts
Top