Honda Ridgeline Owners Club Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
We just bought a 2017 ridgeline a few weeks ago. Have driven maybe 100 miles. We took it in for a fluid leak. Turns out it is a front axle seal that needs to be replaced. Anyone else having this problem? Pretty disappoin, ting for a new $40K+ vehicle. Oh yeah, the dealer called said to come get the truck, they can't get to it for another week. We told them we didn't want it back until it was fixed.:frown::frown:
 

·
Registered
Joined
·
1,766 Posts
There is some bugs that are being worked out on the new ridge. Like every new vehicle always a few kinks to smooth out. But I dont think anyone has had any engine,trans, mechanical issues.
 

·
Administrator
Joined
·
16,062 Posts
First I've heard of a leaking front axle seal and I read about problems and complaints on here multiple times per day, every day. The most common, recurring problem with the 2017 so far is a connector on AWD models that causes a variety of warning messages to appear. The current solution is to replace one or more wiring harnesses after removing the truck bed. Curiously, those complaints seem to have slowed dramatically the last week. Other complaints are more sporadic and are related to panel/trim alignment and a hesitation issue. The only real issue I've experienced so far are some rattles, creaks, and knocks - more so than in any other other new vehicle I've owned that I can think of right off hand - including some older Fords and GMs.
 
1 - 4 of 4 Posts
Top