Honda Ridgeline Owners Club Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hello, I recently purchased a 2019 Ridgeline RTL back in November . So far so good.
Recently on two occasions when starting up engine ,various warning lights came on (engine, power steering, emission, hillside, stability control), they would loop in the front console as well. The car started fine. I turned the engine off , and restarted it, it did it again. After a couple of more on and off it cleared as if nothing happened. Truck drove fine.
Does anyone has had same issue.
If it happens again I am taking to dealer.
Thank you
 

·
Administrator
Joined
·
14,918 Posts
Welcome to the Ridgeline Owners Club, @GVAzq!

There's no way to tell what may have caused the problem without reading the code(s). One problem can generate warnings in multiple systems because they share information between themselves and from common sensors. In your case, you probably have an "Emissions System Problem" which has disabled or could potentially disable some of the other systems, so you get warnings for those as well.

It's best to go ahead and take it to the dealer to have them scan for codes and document your concern.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Welcome to the Ridgeline Owners Club, @GVAzq!

There's no way to tell what may have caused the problem without reading the code(s). One problem can generate warnings in multiple systems because they share information between themselves and from common sensors. In your case, you probably have an "Emissions System Problem" which has disabled or could potentially disable some of the other systems, so you get warnings for those as well.

It's best to go ahead and take it to the dealer to have them scan for codes and document your concern.
Ok thanks... even though it has happened at random times , and seems to be driving well, it should not occur as it’s a new car.
Again thanks for reply
 

·
Registered
2019 Sport Lunar Silver
Joined
·
156 Posts
"Should" is a big word. These cars are mass produced & things can go wrong.
 

·
Registered
Joined
·
1 Posts
I have a 2017 rtl-t. Just over 51K miles and that exact thing happened today. warning lights cycled through the dash 1. Vehicle stability 2. Trailer stability 3. Emissions 4. Power steering and 5. Hill start

I will be taking it into Honda tomorrow. I was just there for an oil change less than a month ago and they said there was no recall. Will it still be covered under the factory warranty? Smh VIN 7010
 

·
Registered
2017 RTL-T 2WD White Diamond Pearl / Black Interior
Joined
·
6 Posts
I have a 2017 RTL-T with just over 49K miles that I have owned for about 8 months. Two days ago this happened as I accelerated up a large hill/residential street. It would not accelerate, started beeping and started cycling through the warnings described above. I thought something broke and pulled over and turned it off. After a while I started back up and although the warning lights were still on, it drove fine. The next day the warning lights were gone. It just so happens I had an oil change scheduled at the dealer today (first two oil changes came free when i purchased). They checked the codes and told me the camshaft needs to be replaced and its under warranty. They also said a few other vehicles have had this problem recently. I found a few different posts here stating the problem was the battery or the alternator or a wiring harness so I wanted to share.
 

·
Administrator
Joined
·
14,918 Posts
I have a 2017 RTL-T with just over 49K miles that I have owned for about 8 months. Two days ago this happened as I accelerated up a large hill/residential street. It would not accelerate, started beeping and started cycling through the warnings described above. I thought something broke and pulled over and turned it off. After a while I started back up and although the warning lights were still on, it drove fine. The next day the warning lights were gone. It just so happens I had an oil change scheduled at the dealer today (first two oil changes came free when i purchased). They checked the codes and told me the camshaft needs to be replaced and its under warranty. They also said a few other vehicles have had this problem recently. I found a few different posts here stating the problem was the battery or the alternator or a wiring harness so I wanted to share.
Camshaft wear is a known problem according to Honda, although we have't seen many (any?) reports of it on this forum.

 

·
Registered
2017 RTL-T 2WD White Diamond Pearl / Black Interior
Joined
·
6 Posts
Got my truck back today and they replaced the following: camshaft, camshaft thrust cover, camshaft position sensor, camshaft pulley.They also adjusted front valves.
 
1 - 9 of 9 Posts
Top