Honda Ridgeline Owners Club Forums banner
1 - 17 of 17 Posts

· Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
Hey everyone - I just bought a 2014 Ridgeline last week and decided to replace both of the front turn signal bulbs with these LED lights
On the right side, took out the stock amber bulb and right when I connected the new LED light, I heard a zap. LED is on, as well as the left side turn signal (with original) but when flipping the stick to turn, there's no blinking sound, nor does the flashing turn arrows show on my dash. Put the original bulb back in and still the same issue. The hazard light also doesnt work and as for the rear turn signal lights, I'm unsure since the turn blinking isn't working.

Anyone ideas to resolve this issue? I have an car appt this Monday but would rather fix it myself.
 

· Super Moderator
2006 Ridgeline RTS in Steel Blue
Joined
·
7,894 Posts
I would guess the turn signal relay has burned out. The bad part is on a weekend not as many users are on here. If you use the search in the blue bar there are several threads on LED light installs. And there is a thread on changing/mods to make the flasher(may have another name) for the cost of a cup of coffee. If I find links I'll add them here. I would hope your planning on returning this to Amazon.

DIY LED Turn Signal Relay (HyperFlash Fix for less than a Cup of Coffee) to me this fix is beyond my skill set. Hazards & Turn Signals Not Working

Site Sponsor Diode Dynamics Relay
 

· Registered
Joined
·
8 Posts
Discussion Starter · #3 ·
Thanks for your input, Carsmak and yea, after doing some research, it looks to be the turn signal/hazard relay. I have an appt this Monday to have it checked out. Felt a bit like an a$$hole, driving around today without using my turn signals as it was raining and that could've been dangerous for drivers behind me.

And...those LED lights are repacked and ready to be sent back.
 

· Super Moderator
2008 Ridgeline RTS in Billet Silver Metallic
Joined
·
24,636 Posts
If it is the turn signal/hazard relay, it is simple to get to and replace. You might try that option before paying a shop to do it for you.

 

· Registered
Joined
·
8 Posts
Discussion Starter · #5 ·
Thanks, Speed. Just bought the turn signal/hazard relay - tried removing the old one but it's stuck, even when it's unhinged from the secure clips. Any suggestion on an easier way of removing it?
 

· Super Moderator
2008 Ridgeline RTS in Billet Silver Metallic
Joined
·
24,636 Posts
I normally use a pair of pliers to remove a relay. I haven't had that particular one out yet, but don't know why it would be secured any different from the others.
 

· Registered
Joined
·
8 Posts
Discussion Starter · #7 ·
The previous one was just a pain in the @ss - it was just really stuck. Put the new relay in and had high hopes for it but still having the same issues. The new relay was so much easier to remove and the previos one was put back into place.

Have an appt tomorrow for it so hopefully everything will be dealt with.
 

· Premium Member
Joined
·
1,825 Posts
Did you check the fuses along with the relay? I would start with checking numbers 4 (small lights) and 16 (hazard) in the primary under-hood fuse box. This is assuming that the fuses are in the same location as in my 2006.
 

· Super Moderator
2008 Ridgeline RTS in Billet Silver Metallic
Joined
·
24,636 Posts
Here are the fuse locations for 2009-







 

· Registered
Joined
·
8 Posts
Discussion Starter · #10 ·
Re: Hazard & both turn signal lights not blinking - RESOLVED

Speed, thanks for the guide, man! Yea, it's exactly the same layout for mine too. It turns out that it was just a blown #16 fuse. Such a simple & cheap fix so you saved me probably about a $100+ at the auto shop. Thanks again Speed & Carsmak! :act035:
 

· Super Moderator
2008 Ridgeline RTS in Billet Silver Metallic
Joined
·
24,636 Posts
I think ridged suggested the fuse check. Good call.

Glad you got it sorted.
 

· Registered
Joined
·
8 Posts
Discussion Starter · #12 ·
Oh man, you're right. Was on my phone when I was checking the forum so somehow didn't realize that it was him. Ridged - thanks, it worked! And thanks again Speed for the fuse location guide!
 

· Super Moderator
2006 Ridgeline RTS in Steel Blue
Joined
·
7,894 Posts

· Registered
Joined
·
1 Posts
Hey everyone - I just bought a 2014 Ridgeline last week and decided to replace both of the front turn signal bulbs with these LED lights
On the right side, took out the stock amber bulb and right when I connected the new LED light, I heard a zap. LED is on, as well as the left side turn signal (with original) but when flipping the stick to turn, there's no blinking sound, nor does the flashing turn arrows show on my dash. Put the original bulb back in and still the same issue. The hazard light also doesnt work and as for the rear turn signal lights, I'm unsure since the turn blinking isn't working.

Anyone ideas to resolve this issue? I have an car appt this Monday but would rather fix it myself.
Was thier a fix? Same problem here
 

· Premium Member
2011 VP Bali Blue Pearl
Joined
·
362 Posts
I know it's a lot of work but you could try and read the whole thread. Solution is about 5 posts above yours. :oops:
 
  • Like
Reactions: FrontRanger

· Registered
Joined
·
1 Posts
Thanks, Speed. Just bought the turn signal/hazard relay - tried removing the old one but it's stuck, even when it's unhinged from the secure clips. Any suggestion on an easier way of removing it?
Re: Hazard & both turn signal lights not blinking - RESOLVED

Speed, thanks for the guide, man! Yea, it's exactly the same layout for mine too. It turns out that it was just a blown #16 fuse. Such a simple & cheap fix so you saved me probably about a $100+ at the auto shop. Thanks again Speed & Carsmak! :act035:
Same for me....replaced the hazard/blinker relay but still didn't work. Turned out be blown 16 fuse.
 
1 - 17 of 17 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top