Honda Ridgeline Owners Club Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
I have noticed something strange on my RTL. When I first turn the heated seats on in either position, and in either seat, there is a delay before the light comes on to indicate they are warming up. It is a fairly long delay also. I haven't timed it but guess it is somewhere between 30-45 seconds. Then the lights will come on and as far as I can tell work like they are supposed to. I have had several Hondas and Acuras with heated seats and none work like this. In my wife's Odyssey when you flip the switch to high or low the "status led light" comes on instantly. Is anyone else's like this? I am wondering if this is normal and not an issue or something I need to keep an eye on. Thanks in advance for any comments.
 

·
Registered
Joined
·
4,075 Posts
The heated seat light turns on immediately when clicked on. Of course, little opportunity for that in SoCal.

Maybe other ROC'rs in colder climates can chime in...
 

·
Registered
Joined
·
5,620 Posts
The heated seat light turns on immediately when clicked on. Of course, little opportunity for that in SoCal.

Maybe other ROC'rs in colder climates can chime in...
Also in SoCal, but wife loves those heated seats on cold mornings....
I believe you are just experiencing intermittent bulb function. My heated seat backlight bulbs started going south (intermittently) years ago. Sometimes they work.... sometimes they don't. I just never bothered changing them. I suspect that if your seats are heating up, that delay is just a contact problem with your indicator bulb(s). If you want to confirm, you'll have to change out the bulb. I've not done that, but I believe there are threads on here that address the how-tos of that.
 

·
Registered
Joined
·
4,075 Posts
I suspect that if your seats are heating up, that delay is just a contact problem with your indicator bulb(s). If you want to confirm, you'll have to change out the bulb. I've not done that, but I believe there are threads on here that address the how-tos of that.
I've replaced all dashboard and seat heater lights with the Radio Shack protocol.

Not a hard DIY at all, just tedious.

Heated seat switch
 

·
Registered
Joined
·
93 Posts
Mine also turn on immediately
 

·
Registered
Joined
·
1,635 Posts
Yep it's the bulb. Nothing wrong with the seats.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #7
Thanks for all of the replies, glad to see I'm not the only one. I will try the quick fix first and change the bulbs out. The bulbs in my overhead light switch are bad also so I will try to do both at the same time!
 

·
Registered
Joined
·
146 Posts
The temperature has been in the teens (F) and I never even thought about using the heated seats.
Oh well, 10,000+ miles in 7 months and I've not considered using cruise control either.
 

·
Registered
Joined
·
5,620 Posts
Thanks for all of the replies, glad to see I'm not the only one. I will try the quick fix first and change the bulbs out. The bulbs in my overhead light switch are bad also so I will try to do both at the same time!
Read up here on those.... some fixes are not as straight forward as you might think (corrosion at contact points for instance).
 

·
Premium Member
Joined
·
1,674 Posts
Interesting. I live in PA and don't have that problem. It comes on right away all the time and I use it almost daily.
 
1 - 10 of 10 Posts
Top