Honda Ridgeline Owners Club Forums banner

1 - 20 of 25 Posts

·
Registered
Joined
·
33 Posts
Discussion Starter · #1 ·
Hello
I have read the other threads about VTM4 and Engine light problems but I think my situation is a little bit different.
I have a 2006 RTS with 109K miles on it. I keep up with the PMs and just recently, like yesterday in fact replaced a dead battery. I noticed on start up, after a few seconds, the Engine light came on and would not turn off. THen a few seconds later the VTM4 light comes on and stays on.
I checked fuse 21, relays, the vtm fuse in the front engine compartment, all are OK. I replaced the VTM4 fluid religiously according to the PM schedhule. What is going on?
Your suggestions are very much in need. Thanks.
 

·
Registered
Joined
·
33 Posts
Discussion Starter · #2 ·
PS two more things I forgot to add
1) I replaced the EGR valve
2) The VTM4 lock button does not seem to work or light up when pressed, R, 1, or 2.
 

·
Super Moderator
2008 Ridgeline RTS in Billet Silver Metallic
Joined
·
23,119 Posts
Are you getting any DTCs?

See if this helps:

 

·
Registered
Joined
·
33 Posts
Discussion Starter · #6 ·
Thanks speedlever, unfortunately I do not have access to testing equipment and cannot get the codes, do you know of a way inexpensively?
 

·
Super Moderator
2008 Ridgeline RTS in Billet Silver Metallic
Joined
·
23,119 Posts
Most autoparts stores will read the codes for free.

Alternatively you can pick up a BT code reader (Elm 327) from Amazon for about $15 and an android app call Torque Pro for $5 and read it yourself.
 

·
Registered
Joined
·
33 Posts
Discussion Starter · #9 ·
Thanks I will try Autozone tommorow.. Appreciate the advice!Have a good weekend, I will let you know what I found out, for the benefit of other members who may be having the same problem.:act035:
 

·
Super Moderator
2008 Ridgeline RTS in Billet Silver Metallic
Joined
·
23,119 Posts

·
Registered
2011 RTL w/Nav
Joined
·
310 Posts
Hello
I have read the other threads about VTM4 and Engine light problems but I think my situation is a little bit different.
I have a 2006 RTS with 109K miles on it. I keep up with the PMs and just recently, like yesterday in fact replaced a dead battery. I noticed on start up, after a few seconds, the Engine light came on and would not turn off. THen a few seconds later the VTM4 light comes on and stays on.
I checked fuse 21, relays, the vtm fuse in the front engine compartment, all are OK. I replaced the VTM4 fluid religiously according to the PM schedhule. What is going on?
Your suggestions are very much in need. Thanks.
If a weak battery was in fact your problem, and you just replaced it yesterday, everything might still work itself out. Sometimes it takes a little time for the electrical system to get totally reset after replacing the battery. I had similar issues once, and the battery was finally replaced. My warning lights came back on one more time (after I left the dealerhip) but no more after that. Hope you have a similar result.
 

·
Super Moderator
2008 Ridgeline RTS in Billet Silver Metallic
Joined
·
23,119 Posts
Most generic code readers will only let you into the engine controller and not the vtm
Well that's a bummer. How to know?
 

·
Registered
Joined
·
18 Posts
Just have to try it. But I know many the cheaper scanners will only do the engine controller. Even the mac/snap-on ones will not give everything a dealer would have access to. But still need to know what the check engine light is and if there is any possibility its related.
 

·
Super Moderator
2008 Ridgeline RTS in Billet Silver Metallic
Joined
·
23,119 Posts
Will the scanner the autoparts stores use be able to do it?

The problem with trying is not knowing what you're missing. In my case, if I have no CEL/MIL, a test will show no codes which doesn't mean squat!
 

·
Registered
Joined
·
18 Posts
Will the scanner the autoparts stores use be able to do it?

The problem with trying is not knowing what you're missing. In my case, if I have no CEL/MIL, a test will show no codes which doesn't mean squat!
He says he has a CEL. The scanner will most likely only read p-codes which are generic. As you can see from the picture you posted the other Honda codes are different like XX-XX. I highly doubt there is a aftermarket that will give you the info a HDS will. But what seems to be your problem that you have no CEL?
 

·
Super Moderator
2008 Ridgeline RTS in Billet Silver Metallic
Joined
·
23,119 Posts
I have no known problems. I'm just inquiring how I can test my OBD2 port scanner to know what it can and can't read.

Edit: actually I have 2 port scanners:
1) Garmin ecoRoute HD device
2) ELM 327 adapter (using a splitter off the OEM port for both devices)
 
1 - 20 of 25 Posts
Top