Honda Ridgeline Owners Club Forums banner

1 - 16 of 16 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
2006 RTL, 98000+ miles.

Noticed the odometer/trip teller was frozen. Also no indication of open doors. Outside temperature unchanged. Tried re-set button, but nothing seem to help.

Any suggestions? Will this have to be fixed at dealership?

Appreciate any help.
 

·
Super Moderator
2006 Ridgeline RTS in Steel Blue
Joined
·
7,376 Posts

·
Registered
Joined
·
44 Posts
Will be watching this thread because our 2006 with 85K has an intermittent display. Battery is only 4 mos old. Could be a different problem since display isn't frozen, it blanks out, and seems to reset if key is turned off and on.
 

·
Registered
Joined
·
579 Posts
Here is another ongoing thread with link to yet another thread that talks about corroded connector, at least that's what I get out of it....Link.
I would start with checking the battery by load testing it and checking positive/ground connections then go from there.
Good Luck
 

·
Registered
Joined
·
19 Posts
I have a similar issue with my 08 RTX
the other morning i noticed the odometer section was frozen and dim
i was unable to select trip modes, etc
everything else is working fine, but odometer is like frozen
I have a new braille battery that i put in a few months ago
yesterday when i noticed this, i pulled the negative cable off, and put it back on
turned the key, and wallaha... display is bright as usual and odometer changed too
on the way home from work, put key in and turn on, and noticed same issue again, dim and frozen, but the display is there, not garbled up or anything
hit the trip button, nothing moves, all other lights in dash function, etc...
when i got home i before shutting off, i hit trip button again, nothing on the display changed since it was "frozen", turned off engine/key, turned key on: same issue, turned key on again, and display came back, showed different trip setting, and went dim/frozen again in 3 seconds

not sure what is causing this and why all of a sudden it happened
i have 22k on it
when it became bright again, the "frozen" odometer reading did change, so did the trip mileage, and i was able to hit the trip button to get oil information when it worked this morning

anyone else have this?
bulbs in the dash all seem good too, so does everything else
 

·
Registered
Joined
·
579 Posts
The link I posted also links to another thread stating that the LCD connection could be loose or need cleaning.
 

·
Registered
Joined
·
7 Posts
Have a 08 Ridgeline with this flickering odometer display. Same story as the other poor guys.. Stealership wanted $920 bucks to replace the whole cluster. Found a company in Deluth GA that promised a fix for $125. I'm now a very fast cluster remover expert on my truck. Took it out, used contact cleaner on all pin connector areas. Reinstalled it, no change. Took it out, shipped it to Deluth, GA. 11 days later, put it back in, and no change. Cried and pleaded to the company in GA. They said, we'll pay shipping both ways, and honored their warranty. Took it out (3rd time), and they sent it back with my refund and said they could not fix it! I'm not sure what repairs have been attempted, but just like the other posts, it flashes, flickers, and shows egyptian hieroglyphics frozen sometimes on colder days. I'm in NC so on hotter days it's fine. Can anyone send some pics or video of this delegate procedure? I didn't think I could get all the way inside where this pin is located on the cluster. But I remember seeing the small opening in the bottom. Thanks for any help. The Capt.
 

·
Registered
Joined
·
7 Posts
Ok! Here’s the fix for your 06, 07, or 08 Ridgeline with flashing and flickering odometer LCD display. There’s a company in Racine, WI (which I’ve only heard of in the move “ A League Of Their Own”) They make a new LCD screen and looks like they are the only ones making these. Honda wants you to buy a new cluster.
Jason - Owner
Tanin Auto Electronix
262-456-4147
They even have a do it yourself video on YouTube for the ones who dare to try. Since I’ve taken my cluster out twice to send it off for no repair, I was way too familiar with snatching out my cluster and snapping in the company’s new LCD. Part and shipping was about $70 bucks.
If you’ve lost all display and have ——— just dashes showing then this is probably not your fix. But if you have the Klingon sandscripe that flickers, flashes, and goes dim, especially in colder weather??? This should do it. I was almost to the stealership with $940 bucks but finally found my new best friend in this company. Here’s a link. Hope everyone with the same problem can get this fix. == The Captain.
YouTube
2006 2007 2008 Honda Ridgeline Speedometer Odometer Screen LCD Repair Service Installation

Tanin Auto Electronix Speedometer Repair, Odometer Correction, LED Customization, and DIY Parts
 

·
Registered
Joined
·
2 Posts
I have a similar issue with my 08 RTX
the other morning i noticed the odometer section was frozen and dim
i was unable to select trip modes, etc
everything else is working fine, but odometer is like frozen
I have a new braille battery that i put in a few months ago
yesterday when i noticed this, i pulled the negative cable off, and put it back on
turned the key, and wallaha... display is bright as usual and odometer changed too
on the way home from work, put key in and turn on, and noticed same issue again, dim and frozen, but the display is there, not garbled up or anything
hit the trip button, nothing moves, all other lights in dash function, etc...
when i got home i before shutting off, i hit trip button again, nothing on the display changed since it was "frozen", turned off engine/key, turned key on: same issue, turned key on again, and display came back, showed different trip setting, and went dim/frozen again in 3 seconds

not sure what is causing this and why all of a sudden it happened
i have 22k on it
when it became bright again, the "frozen" odometer reading did change, so did the trip mileage, and i was able to hit the trip button to get oil information when it worked this morning

anyone else have this?
bulbs in the dash all seem good too, so does everything else
did you ever ID the cause and resolve this? I have the identical issues with the new to me 06 RTL. For a couple hundred I would like to fix this but for a large expenditure I will likely just live with it.
 

·
Registered
Joined
·
33 Posts
In cold weather mine...freezes and after a while/new startup it actually catches up the OD and mileage so I'm not worried my 74,000 mile 06 RTL is really a 200,000 mile RTL lol but I would like to fix it..
 

·
Registered
Joined
·
2 Posts
Mine never seems to catch up while driving but always resets to current mileage after startup. Really annoying but the only thing I really look at regularly on that display is the outside temp. Hopefully someone has identified and repaired this and will shar what they learned.
 
1 - 16 of 16 Posts
Top