Honda Ridgeline Owners Club Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I installed a Pioneer FH-X720BT head unit over the weekend. After watching enough videos and reading the forums, I believe I have everything hooked up correctly, but I am only getting sound out of the front right and back left speakers.

Anyone know a solution for this?
 

·
Premium Member
Joined
·
388 Posts
Have you double checked your wire harness? Also double check settings on deck. Could be as simple as either wired not hooked up properly, or check connection at speakers.. Did you have issue with previous deck??
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Thanks for the reply. I did not have any issues with the factory head unit.

I have to open it back up to connect the hazards, which I forgot to do, so I will make sure all the wires are connected right, but I am almost certain they were correct when I installed it.

The instructions mention a setting rear-sp which might fix my problem but it is not in the menu of my head unit. The only settings mine has is for a subwoofer.
 

·
Premium Member
Joined
·
388 Posts
Possible could be setting on head unit.. The pioneers offer a option to shut rear speakers off and speaker volume levels
 

·
Premium Member
Joined
·
1,817 Posts
I installed a Pioneer FH-X720BT head unit over the weekend. After watching enough videos and reading the forums, I believe I have everything hooked up correctly, but I am only getting sound out of the front right and back left speakers.

Anyone know a solution for this?
Unfortunately, the "solution" is answering more questions.

When you purchased the Pioneer, was it supplied with a wiring adapter? If so, it's pretty difficult to cross wire left/right, front/rear. *most of the time*, it's a color-for-color connection.

Were all speakers functional prior to HU install?

The answer to those questions is important to diagnosis.
 

·
Registered
Joined
·
13 Posts
I just installed the exact same unit in my truck. There are individual sound settings to adjust the balance and fade. If its not those its going to be the wires.
 
1 - 6 of 6 Posts
Top