Honda Ridgeline Owners Club Forums banner

1 - 20 of 114 Posts

·
Registered
Joined
·
58 Posts
Discussion Starter #1
Hi

Just want to keep touch with everyone here.. Is anyone having this error before on your RL?
"Keyless Start System Problem" on ther dask consiole screen.

Is this a known issue? or common problem?

TIA
 

·
Registered
Joined
·
56 Posts
That could indicate a number of issues, however, the most common would that your key fob battery is low/dead or the signal from the fob is being interfered with. Try holding the fob next to the start button when you try to start it. If that works, you'll need a new battery for your fob. If it doesn't, you'll need code reader to see what's going on.
 
  • Like
Reactions: radiowc

·
Registered
Joined
·
16 Posts
I actually just started getting this message this month as well. Seems like it's a big or common issue on Pilots but yours is the only one I see here with the Ridgeline. I know it's not a battery issue as mine was just changed in the last month. Weird thing has been that it seems completely random when I get it. Sometimes I'll get it for an entire day every time I start and then I won't see it for 3 or 4 days.
 

·
Registered
Joined
·
729 Posts
Pilot owners are replacing the start/stop button assembly to correct the problem. RL/Pilot part number: 35881-TG7-702
 

·
Registered
Joined
·
29 Posts
I’ve been aging this off and off for a few months.
 

·
Registered
Joined
·
58 Posts
Discussion Starter #7
Same here. Mine only got cleared after i used the second key fob and then back to the main fob. The alert seem cleared and have not show up again since then. Well surely keep an eyes on it. Will keep you guys posted/update if any changes/
 

·
Registered
Joined
·
5 Posts
Hi

Just want to keep touch with everyone here.. Is anyone having this error before on your RL?
"Keyless Start System Problem" on ther dask consiole screen.

Is this a known issue? or common problem?

TIA
Had this message pop up off and on. Honda finally figured out that the engine start button was going bad. Was replace for free under the certified warranty.
 

·
Registered
Joined
·
16 Posts
Had this message pop up off and on. Honda finally figured out that the engine start button was going bad. Was replace for free under the certified warranty.
In other words, it probably is something that I need to get fixed. As random as it was, I wasn't sure if it was worth even messing with since it didn't give me any problems other than the message.
 

·
Registered
Joined
·
58 Posts
Discussion Starter #10
Hello All

Just to update/follow up. I bring it to my dealer, and they able to reproduce the error. and the code is "B12C5". and they replaced the following parts 35881-TG7-A03 Switch Assembly and 7251A2 switch, engine start. Surely not due to the fob battery :) IF you have the same error.. have the dealer fixed it before your warranty went out.Glad mine still does. if not you will have to pay about 165.56$ (including labor)

Hope this help

Cheers!
 

·
Registered
Joined
·
6 Posts
Yep, just started getting this on mine the other day. I live an hour and a half from the dealer and of course I am past my warranty (46k miles). Grr.
 

·
Registered
Joined
·
6 Posts
Update from me. Had to make the one and a half hour into the big city today anyway so I took it to the dealer. They told me they were too busy, but gave me a loaner and said they would have it fixed in a few days. In their words, they didn't want for me to get stranded with it not working at all. Ok, I guess. On my way home I get a call from the service department, the guy said it was throwing "a bunch of codes all centered around that switch. We have ordered the part and will have it fixed for you in the next couple of days. The cost is $315." Needless to say, I am not a happy camper. Between my wife and I, 9 years with a brand new Camry, 11 years with a brand new Frontier, and currently 6.5 years with a new Highlander, not one problem between the 3 vehicles. 3 years and one month with the Ridgeline, and this problem happens. This doesn't include the middle passenger seatbelt I had to have replaced because it was installed incorrectly or the numerous plastic body panels I have to constantly snap back into place. Very frustrating, and it has me asking, what's next?
 

·
Registered
Joined
·
412 Posts
No longer under warranty?
 

·
Administrator
Joined
·
16,342 Posts
I was told by the dealer, I need to replace the start stop button. How do I get the trim off the dash?
Remove dashboard side lids - 6 clips
Remove drivers dashboard lower cover - 12 clips, electrical connectors, aspirator hose
Remove passengers dashboard trim panel - 15 clips
Remove dashboard center panel - 2 clips
Remove dashboard center trim - 3 screws and 14 clips
Remove start/stop button - 2 clips

What are the symptoms?

I do not have a clue but have you searched you tube to see if anyone has posted a how to video?
Heck I did a search for you. :)
That video is for a first-generation Ridgeline.
 

·
Registered
Joined
·
10 Posts
Yes I tried YouTube but that is different dash than I have. Mine is the Sport, no navigation. Zroger73 I wish you had pics. It sounds like you know what I want to do.
 

·
Administrator
Joined
·
16,342 Posts
Steps 1-8 of the attached accessory CD player installation instructions should be helpful.

I ask again, can you explain the symptoms in more detail? I'm not yet convinced the start/stop button is the problem.
 

Attachments

·
Registered
Joined
·
10 Posts
I went to the dealer and had my old changed they have to reset the oil program however that’s done I’m sure it’s electrically. On the way home I noticed I had an era code keyless entry problem I thought my battery was dead in the key fob so I replaced the battery. Still same code so I tried the second fob and got the same code. I head back to the dealer to let them know that this happened after oil change. I was told one had nothing to do with the other. To repair it would be $450.
 
1 - 20 of 114 Posts
Top