Honda Ridgeline Owners Club Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
Has anyone installed a Metra ASWC on a 2012? The ASWC website says this is NOT supported so I emailed them and they said that the electrical schematics for 2012-13 ridgelines look the same as previous years but they have not officially confirmed that the ASWC module actually works on 2012-13 models.

Sounds like it should, but I would like to confirm before performing the install if at all possible. - Thanks.
 

·
Registered
Joined
·
3 Posts
Yes it does work, but auto detect did not work, at least in my case. Programming it was pretty easy though. Funny thing is auto detect was a key feature for me choosing the Metra.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #3
Interesting. Are the manual programming instructions included? Auto detect is also my main reason for choosing Metra. I wonder what changed between 2011 and 2012.
 

·
Registered
Joined
·
3 Posts
Yes the programming instructions were included.

I went back and looked at my notes (it's been a few months since I did the install), and it looks like my main issue was that in auto detect it mis-identified the radio manufacturer. My radio is a Clariion NX-702. It may be that auto detect will work with a different model/brand.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #5
I finished my install and it works fine on a the 2012. The installation instructions for the ridgeline did change in 2009 I believe so make sure to use the latest. I emailed Metra to confirmed that it worked so I'm guessing they'll update the website eventually.

Great product. My only real minor complaint is I would have preferred the ch+/ch- to control the channel presets rather than control the channel. In FM mode selecting the ch+ basically searches for the next FM station higher than the current number. I'll try to reprogram manually so ch+ goes to next preset station.

Here are the two wires you need to spice on the factory harness.

 

·
Registered
Joined
·
121 Posts
I installed the Metra ASWC with my Pioneer head unit and it mostly works well. It automatically configured itself to work with my system. My only complaint is that it occasionally stops working for a short time. I usually notice it shortly after starting the vehicle and driving a short distance. After a while, it starts working again without any particular action on my part. Perhaps mine has a defect that causes this relatively rare malfunction.
 
1 - 6 of 6 Posts
Top