Honda Ridgeline Owners Club Forums banner
1 - 20 of 26 Posts

· Registered
2021 Honda Ridgeline EX-L Canadian
Joined
·
1,603 Posts
Must be the wire going to the thermostat. Or something like that. Your LED display appears to work.
 

· Registered
2009 RTS
Joined
·
805 Posts
Why is everything in MPH if it's from Canada.. Eh!
Many cars are made in Canada for the US.
.

Arsenal16, search the forum and do the HVAC test first.
The sensor is on the front drivers side of the radiator at the bottom.
 

· Registered
Joined
·
41 Posts
Discussion Starter · #7 ·
Many cars are made in Canada for the US.
.

Arsenal16, search the forum and do the HVAC test first.
The sensor is on the front drivers side of the radiator at the bottom.
It was originally sold as a Canadian vehicle but when it was transferred to the states the odometer was changed from kilometers to miles. How do you do the HVAC test ?
 

· Registered
2009 RTS
Joined
·
805 Posts
There is a sensor test you can do also using the HVAC if memory serves me correctly.
You could also pull and test the sensor w/ a multi-meter.
A new sensor is around $40 usd if it's bad or you could have a bad connection at the lcd panel.
.
 

Attachments

· Registered
2009 RTS
Joined
·
805 Posts
Climate Test just in case you didn't find it.
.
 

Attachments

· Registered
2009 RTS
Joined
·
805 Posts
If the Climate Test and the Sensor Test showed good, then the problem is between the sensor and the lcd panel.
My guess would be the lcd connection.
 
1 - 20 of 26 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top