Honda Ridgeline Owners Club Forums banner
1 - 20 of 23 Posts

· Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hey folks, need some help.
Have 142k on my 2008 RTX that I purchased brand new. Figured I would treat her to some new struts (Monroe was running rebates).
I bought 4 new struts and new mounting kits. Installed the fronts with new strut mounts/bearings, and had to replace the sway bar links.
Everything seemed to replace nicely, but it sounds terrible!
The springs seem to be sticking against the upper mounts (you can see the springs jumping as the wheels are turned back and forth) and there is a clunking sound now going over bumps.
I followed instructions I found on this site, and am pretty sure we followed them correctly.
Thinking I did something stupid, so looking for someone who has been there done that to clue me in to my error.
thanks in advance for your assistance!

-Al
 

· Registered
Joined
·
5,700 Posts
I'm going by memory, but I believe I remember that there is a right hand and a left hand "top bearing" assembly, or whatever it's called. So if you've got those reversed, that would be a problem. Also, be sure you reinstalled bump-stops on the shocks..... it sounds like you did a part by part diy, so that's why I'm mentioning that. Lastly, check to see that you didn't have your sway bar bushings get out of place (or pieces fall off?) when you replaced the end links. The end links are probably also RH/LH specific, so be sure those aren't honked up either.
 

· Registered
2009 RTS
Joined
·
805 Posts
Everything Dnick said and the bearing assembly has a orientation mark I think. Even tho it's 3 bolts, 1 should be marked FR for front I think. Also the ends of the springs should have went back into the top & bottom plates where there's a indent.

Here is a vid of a odyssey by EricTheCarGuy that may help....

https://www.youtube.com/watch?v=UpSIv3mk98k
 

· Registered
Joined
·
4 Posts
Discussion Starter · #5 ·
Sorry guys, didn't see the replies.

These are Monroe OE Spectrum struts, and the Monroe Strut-Mate mounts. The mounts are marked with "FR", don't think there is a differentiator right/left on the mounts as there is only one part#. I DO now see that there is a right/left link, so may be part of my issue.

Will check it out and advise.

Thanks!

-Al
 

· Registered
Joined
·
5,700 Posts
Yeah, all of those 'top mounting' parts are interchangeable left to right. As far as the shock parts go, only the shock spring & main shock unit itself, and the rubber seat the spring sits on are left/right specific. The shock unit itself would be hard to put on backwards without noticing.... the brake line connects on different sides, I believe.

 

· Registered
2009 RTS
Joined
·
805 Posts
@14:40 in the vid, he shows a left and a right side. I also searched autozone and they show 2 different part #s as 1 is Left and other is Right as noted in the Notes section.
 

· Registered
2009 RTS
Joined
·
805 Posts

· Registered
Joined
·
4 Posts
Discussion Starter · #10 ·
Guys- know its been awhile on this, but important update. After replacing the from mounts twice with no change, went back to Monroe who acknowledged that there was a known issue with the front mounts. They sent me a modified version right from manufacturing, but I had the same problem. Technician then told me they were moving manufacturing for that part to a new supplier and offered me a refund.
I purchased new OE complete units and they were flawless from day one.

Anyone in same position buy the OE units.
 

· Premium Member
Joined
·
11,332 Posts
I don't think anyone had that issue with the KYB. They make them for Honda too, which may be the reason.
 

· Registered
Joined
·
3,082 Posts
Respectfully, some things are worth getting done by professionals.
 

· Registered
Joined
·
228 Posts
Moog, KYB and SACHS all make the upper strut mount. $39-42 from Rockauto. OEM Majestic for the same strut bearing is $56. I would have gone with the KYB except I was buying an engine side mount at the same time that Rockauto didn't have so did OEM for both.
 

· Registered
Joined
·
21 Posts
Guys- know its been awhile on this, but important update. After replacing the from mounts twice with no change, went back to Monroe who acknowledged that there was a known issue with the front mounts. They sent me a modified version right from manufacturing, but I had the same problem. Technician then told me they were moving manufacturing for that part to a new supplier and offered me a refund.
I purchased new OE complete units and they were flawless from day one.

Anyone in same position buy the OE units.
Monroe ain't what they used to be either. I don't know if I'll EVER buy Monroe shocks again after having bought a set for my Suburban and they rode like the ones that came off.
 

· Registered
Joined
·
12 Posts
3 Questions

1. Is the concensus buy the Honda parts? I was set on acquiring Moog hardware and either KYB or Monroe strusts.

2. Is it more efficient to buy the complete assembly (shocks and struts-complete units) for about $1000?

3. Does anyone have the dhop manual for this service?
 
1 - 20 of 23 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top