Honda Ridgeline Owners Club Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hey guys,

So I had a local shop install some PIAA G3 low beams for the Ridgeline. THEY ARE REAL GOOD!! Amazing light output.. they better be for the price.

Anyway though, there was an oddity attached to this installation.. the headlights (the lowbeams) don't come on when I turn the lights on! However they DO come on when I turn the foglights on (and the foglights come on too). The tail lights still come on as normal when I turn on the lights but if I want the headlights on I need to turn on the foglights!

To be honest I'm conflicted because the lights work GREAT and are aimed perfectly and I do drive about 40% of the time with the foglights on @ night but my perfectionist side doesn't like the fact that obviously something isn't wired up correctly.

Do you guys know what might be causing this odd issue? Would it be an easy fix?

Thank you for your time, have a great Sunday!
 

·
Registered
Joined
·
374 Posts
Those are plug and play. They should come on with headlight switch UNLESS shop installed a relay system and they are getting Power source from fog light instead of headlight.

Go back to shop and get it fixed by them. Sounds like they did additional wiring and it was improper.
 

·
Registered
Joined
·
149 Posts
The other reason you need this fixed is for high beams, those will turn off fogs but you want to retain low beams for maximum light!

Mike
 
1 - 4 of 4 Posts
Top