Honda Ridgeline Owners Club Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1 (Edited)
Hello everyone!

I just purchased an RL last week. It's a 2008 RTL w/ 140k miles. It seems to have been taken care of quite well with most major stuff having been reportedly done by a dealer (timing belt/tensioner/water pump/ serpentine @ 105k, radiator, front brakes, some type of seal/gasket, new tires, etc.). However, after a few days of owning it I had a CEL pop up. OBD-II showed a few codes 81 and a P0420. I've been reading through all the threads about the O2 sensors/cats and know the P0420 is for Bank 1 closest to the firewall.

I crawled under the RL last night and was looking at the cats & O2 sensors to see what condition they were in. (That Bank 1 is in a tight spot, man I wish it was Bank 2 up front.) My question is: Does anybody know what color the original O2 sensor cable jacket is?

The wires are orange like the replacement NTK O2s that I've been shopping around for. I'm trying to figure out if these may have been replaced (maybe OEM was black wire?).

Thanks for any insight that you may have!
 

·
Administrator
Joined
·
17,303 Posts
The OE pre-cat air-to-fuel ratio sensors for banks 1 and 2 have black, gray, white, yellow, and blue wires.

The OE post-cat heated oxygen sensors for banks 1 and 2 have black, gray, white, and white wires.
 

·
Registered
Joined
·
12 Posts
Discussion Starter #3
Thanks zroger73. I'm guessing you're referring to the individual wires themselves? (I think they're four or five pin harnesses if I recall correctly.) I was more specifically inquiring about the jacket on the cable that is visible from the engine compartment or from under the car.

I see what appears to be the middle option (downsteam, rear) at Autozone here: https://www.autozone.com/engine-management/oxygen-sensor?filters=4294761171 w/ the orange jacket cable on my RL.

I was hoping that this might be an easy indicator that someone has already replaced the O2 sensors (i.e. the OEM stock ones were black/gray/whatever color).
 

·
Registered
Joined
·
2,564 Posts
Hello everyone!

I just purchased an RL last week. It's a 2008 RTL w/ 140k miles. It seems to have been taken care of quite well with most major stuff having been reportedly done by a dealer (timing belt/tensioner/water pump/ serpentine @ 105k, radiator, front brakes, some type of seal/gasket, new tires, etc.). However, after a few days of owning it I had a CEL pop up. OBD-II showed a few codes 81 and a P0420. I've been reading through all the threads about the O2 sensors/cats and know the P0420 is for Bank 1 closest to the firewall.

I crawled under the RL last night and was looking at the cats & O2 sensors to see what condition they were in. (That Bank 1 is in a tight spot, man I wish it was Bank 2 up front.) My question is: Does anybody know what color the original O2 sensor cable jacket is?

The wires are orange like the replacement NTK O2s that I've been shopping around for. I'm trying to figure out if these may have been replaced (maybe OEM was black wire?).

Thanks for any insight that you may have!
The orange one you referenced is for a downstream sensor. You mentioned bank 2 but didn't say if you were talking Air-Fuel Sensor (upstream) or Oxygen Sensor (downstream). (Note: there are four sensors on the Ridgeline).

The upstream and downstream are NOT interchangeable. If you have a downstream upstream...that's probably your problem.
 

Attachments

  • Like
Reactions: Carsmak
1 - 5 of 5 Posts
Top