Honda Ridgeline Owners Club Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
774 Posts
Discussion Starter #1
I've begun to smell a pungent odor coming from the air ducts when I fire up (ooopps, sorry don't mean to bring up a sore subject) my Ridgeline. It's just an odor, no smoke (thankfully). It goes away after a couple of minutes. This is not the first Honda that has done this to me. Any similar experiences or suggestions?
 

·
Registered
Joined
·
406 Posts
denvrfan - There was a recent post mentioning your absence. Glad to know you are back.

There is another recent thread about odors when running the heater, maybe your problem is related. Do a search for smell, odor, heater and I am sure you'll find it.
 

·
Registered
Joined
·
1,611 Posts
Check the bottom of your shoes lately? Got a dog? :eek:

Just kidding! Ditto everything that Grok Lobster said! No odors other than one time that I smelled something that smelled like an overheated electric motor. It was right after a sudden onset of driver induced maximum acceleration. Haven't smelled anything since.
 

·
Registered
Joined
·
774 Posts
Discussion Starter #4
Grok Lobster said:
denvrfan - There was a recent post mentioning your absence. Glad to know you are back.

There is another recent thread about odors when running the heater, maybe your problem is related. Do a search for smell, odor, heater and I am sure you'll find it.
Thanks- haven't gone anywhere- still try to check in daily (at least during the work week- it's a lunchtime activity). I just haven't seen as much to comment on lately.
 
1 - 4 of 4 Posts
Top