Honda Ridgeline Owners Club Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
40 Posts
Discussion Starter #1
Bought my RL about a year ago and the A/C has never been quite right. I added some refrigerant last summer, then let some out as I think I had too much (compressor was going on and off to quick). I didn't use it too much last year because I knew it didn't have a proper charge.

This year I took it to a shop and gave it a evac and charge (they said it was low). It worked well for a couple weeks then it stopped blowing cold air. Took it back to the shop, the condenser is leaking. They wanted $500 to change it out and recharge, but I've done a condenser change before on my wife's car so I decided to buy the part and put it in myself to save a few hundred bucks. I'll take it back to the shop to get charged up.

The guy at the shop recommended I drop in some oil into the condenser before I install. I'm trying to do some research on here to see if anyone's changed it before and how much oil to add. I just bought the oil from my local parts store. If anyone's done this on their RL before, please let me know any tips.

I'm going to go outside and start pulling it apart.
 

·
Registered
Joined
·
40 Posts
Discussion Starter #3
Thanks! Exactly what I was looking for. Unfortunately, I just eyeballed it aiming for about 2oz. So hopefully it works out ok. I must have checked the post right before you posted this.

Looks like my truck had been involved in a crash in a previous owner. The support that runs down the middle of the condenser was bent inward and I had to yank on it with a strap to straighten it in order to get the new one in. I couldn't get it to line up perfectly, but it's solid in there. Seems like its a bit low. Maybe something with the bottom mounts are damaged too.

Will take it to get charged tomorrow and hope for the best.
 

·
Registered
Joined
·
40 Posts
Discussion Starter #4
A week later and its working good. A/C is nice and cold.

I notice the condenser makes a "clunk" sound when it first kicks on after starting the car. One day I was idle in a parking space and I could hear the condenser going on/off at about 6 sec intervals.

Does this sound normal for the RL?
 

·
Registered
Joined
·
3,022 Posts
A week later and its working good. A/C is nice and cold.

I notice the condenser makes a "clunk" sound when it first kicks on after starting the car. One day I was idle in a parking space and I could hear the condenser going on/off at about 6 sec intervals.

Does this sound normal for the RL?
Yes, it makes a clunk when it engages.
 

·
Premium Member
Joined
·
7,332 Posts
A week later and its working good. A/C is nice and cold.

I notice the condenser makes a "clunk" sound when it first kicks on after starting the car. One day I was idle in a parking space and I could hear the condenser going on/off at about 6 sec intervals.

Does this sound normal for the RL?
I think you're confusing the condenser with the compressor. The compressor cycles on and off.
 
1 - 7 of 7 Posts
Top