Honda Ridgeline Owners Club Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Good day,

I'm reaching out to see if anyone else experienced such problems. Basically, it started with a check engine light turning up because of the cap less funnel.

I got it changed at the dealer, the light turned off, but still can't pump gas properly. I have to trickle gas in very, very slow. I can't press the trigger in full, I need to control it to be 1/10th engaged. Some gas stations are even worst.

I've linked a video of what happens when I press the trigger in normally at a gas station.

I went 3 times to the dealer and every time they say it's fixed, which is bull, cause this video was right after picking it up from the dealer.

Filling up Problems at gas station

Any idea what could cause this ? The filler part was also changed at least once, from what they say.

Thank you for your help.

Cheers
 

·
Registered
Joined
·
519 Posts
Call Honda corporate -- dealer has had 3 chances to fix same issue over and over again and you're able to show them they didnt fix it, practically IMMEDIATELY. You're in Canada too -- do they have consumer protection laws for this sort of thing?

Also speak to gen mgr of entire dealership, tell them it's NOT ok and that you're tired of doing their job for them. Each time you easily show they didnt fix, you essentially show they didn't even bother to check if it's fixed.
 

·
Registered
2019 Sport Lunar Silver AWD
Joined
·
566 Posts
See TSB linked below. Not being able to fill the tank is a caused by a blockage in the EVAP vent. When filling the tank,the displaced air has to go somewhere. The system is designed to vent thru the EVAP canister to the atmosphere. If the vent is blocked the tank will attempt to vent thru the fuel filler, pushing fuel back up the filler tube which triggers the gas station pump to shut off. The dealer should have caught this as not being able to pump gas is a classic symptom of a blocked vent. I’d try another dealer if convenient.
 

·
Registered
2019 Sport Lunar Silver AWD
Joined
·
566 Posts
Apparently you are not the first person to encounter this problem. Do you know what DTC caused the CEL? Was it P2422?
 
1 - 5 of 5 Posts
Top