Honda Ridgeline Owners Club Forums banner

1 - 17 of 17 Posts

·
Registered
Joined
·
55 Posts
Discussion Starter #1 (Edited)
I basically followed Jasons how to here.

I used this bar from Amazon. however i found that i didnt need to trim back much of the black plastic in the opening. just right on the very ends where is a bit deeper. i mounted the bar as far back as it would go. its resting on the metal bumper and secured via some thick metal brackets that i fabed up and mounted to some factory holes with factory 10MM bolts.

i also used a 30A relay and wired it into my high beam lights. +12 from the under hood fuse block and input for the relay from at the pass side headlight harness.


 

·
Registered
Joined
·
55 Posts
Discussion Starter #5
wow its stupid bright! pulling in our driveway. mind you with live in the country so its pitch black



 

·
Registered
Joined
·
2,517 Posts
Would be interesting to see how much light the led bar by itself puts out in that country road setting
 

·
Registered
Joined
·
47 Posts
i have a 2014 RTL and have installed a 30''x1'' single light led bar and it is super bright,since i installed it i only use the parking lights and the bar.
 

·
Registered
Joined
·
55 Posts
Discussion Starter #12
Wow. That's pretty bright. Can you post some pics of the mount/bracket?
didnt take pix. its just some L shaped brackets that i bent to fit into the factory holes. installs are going to be different so its not a standard bracket.
 

·
Premium Member
Joined
·
3 Posts
Evnash, did you have any problems with the light bar turning off when you turn your hi beams off? I have a similar install but there is enough voltage (about 2.5v with the engine running) to keep my relay from switching off when I turn the highs off. The only reference I can find to this is below but I have tried his solution but no change and because it is archived I don't know what year RL he had. Thanks for any information you have.

http://www.ridgelineownersclub.com/forums/archive/index.php/t-103458.html
 

·
Registered
Joined
·
55 Posts
Discussion Starter #14
Evnash, did you have any problems with the light bar turning off when you turn your hi beams off? I have a similar install but there is enough voltage (about 2.5v with the engine running) to keep my relay from switching off when I turn the highs off. The only reference I can find to this is below but I have tried his solution but no change and because it is archived I don't know what year RL he had. Thanks for any information you have.

http://www.ridgelineownersclub.com/forums/archive/index.php/t-103458.html
My RTL has dedicated DLRs that are separate from the headlights. so when my high beams are on i get a constant 12v to turn the relay on. i suspect your DLR are integrated into your headlight and they work with lower voltage.
 

·
Registered
Joined
·
9 Posts
Sorry to revive an old thread. I can't see the pictures on this. Could you repost for posterity? Any issues with overheating?

Thanks!
 

·
Registered
Joined
·
55 Posts
Discussion Starter #17
Sorry to revive an old thread. I can't see the pictures on this. Could you repost for posterity? Any issues with overheating?

Thanks!
reposted old pix of exterior. no issues with overheating at all.
 
1 - 17 of 17 Posts
Top