Honda Ridgeline Owners Club Forums banner

181 - 186 of 186 Posts

·
Registered
Joined
·
126 Posts
Taking the glove box off is simple....so is the blower motor itself. Finding where the other end of the harness plugs into might be a problem. I have pulled my blower motor out before but I don't remember if that harness goes all the way up into the dash.
 

·
Registered
Joined
·
1 Posts
The connector for the blower motor connects to the wiring harness on the firewall side of the center console.

On a 2008 we had a similar problem of failure of the blower motor. At first look the fuse in slot 21 was not blown and the blower ran when 12v was applied to the connector. So it had to be in the switches or wiring harness. The connectore behind the center console had overheated at the connector for the blower motor, causing the plastic to become soft and the connection broken.....stopping the heater from running.
The connector alone is not available from Honda. The ENTIRE wiring harness must be purchased! This entails 9 hours of labor to replace!
An option was cutting the wire powering the fan motor on each side of the connector and soldering in a new connector on each side.This worked. A small connector was made from parts at Radio Shack and a pigtail of wire was soldered to each side. The hot side of the wiring harness should be the soldered to the female side of the connector.
The soldered joints were covered with shrink wrap to insulate the connections.

The question remained. "What caused the connector to overheat?"
Tracing the wiring in a Honda manual, the 40 AMP fuse #21 on the passenger side, under the hood only powers the fan motor. This alerts us to a possible design flaw. The motor was drawing more amps than the circuit connectors could handle - thus they melted - however the fuse did not blow. This could explain fires behind the dash on earlier models. Honda may have had a recall in 06 and replaced the wiring harness with heavier gague wire, but the continue problem seems to be a motor that may draw greater amps with age, yet won't blow a fuse before connectors melt.

We are repairing the wiring by installing a connector soley for the blower and by replacing the blower motor.
 

·
Registered
Joined
·
3 Posts
I am planning on replacing my blower motor, harness, and transistor in a couple of days. I have been having problems with the blower motor just shutting off and coming back on at no controllable time (when switches are left on), regardless of hot, cold, or just vent air setting. However, my truck is 2008 and has no recall ability, so I have to take care of the costs myself.
Anyone have the same problem on the later models? I have been smelling wire insulation burning, and thought it was another vehicle, kinda low smell, and windows open in Oklahoma.

On a similar subject, when it is nice outside and I just want vent air, the air coming out seems heated. Can this be adjusted without turning on the A/C?

2008 Dark Cherry RTX, 142,000+ miles and counting 6/25/14.
 

·
Registered
Joined
·
2,445 Posts
I am planning on replacing my blower motor, harness, and transistor in a couple of days. I have been having problems with the blower motor just shutting off and coming back on at no controllable time (when switches are left on), regardless of hot, cold, or just vent air setting. However, my truck is 2008 and has no recall ability, so I have to take care of the costs myself.
.
+1 .. No smells but similar symptoms.. I've replaced the blower and that did help as the HVAC had completely stopped working.
 

·
Registered
Joined
·
1 Posts
Anyone have this problem after the recall was fixed? I bought my 06 Ridgeline in 2011, and according to the recall site (NHTSA) it was already done. But it appears I may have the same problem. I just swapped out the control unit, thinking that was the problem - but nothing changed. The dials and buttons all work, but the fan does not. Now, I should add that I recently had the windshield replaced... The fan still worked, but quit a week or two later. Don't know if this has something to do with it, or just a coincidence.
 

·
Registered
Joined
·
38 Posts
Just had this recall done on our 07 yesterday (was in for the airbags and this was still showing in the system as "open"). Never had an issue prior but now I'll be keeping an eye on it I guess.
 
181 - 186 of 186 Posts
Top