Honda Ridgeline Owners Club Forums banner
1 - 6 of 6 Posts

· Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
2006 Ridgeline turn signals and hazards stopped working. I read some forum posts and did a little research. In my search and talking to others, I found there is no fuse. Decided to change the turn signal relay and still not working. Any help is appreciated before I give in and take it to the dealership.
 

· Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Rigid - that was a big help. Thank you. I found the fuse and replaced it...twice. It will work for about 5-10 min, then goes out, again. I replaced the relay and that didn't work, either. This appears to be a short. Any suggestions on how to find the short? I understand it can be timely. Any good recommendations are appreciated. Thank you!
 

· Super Moderator
2008 Ridgeline RTS in Billet Silver Metallic
Joined
·
24,636 Posts
Tell us about any mods on your RL. Do you have a hitch installed? Is it factory or do you have a 3rd party wiring harness?
 

· Registered
Joined
·
5 Posts
Sounds like a bulb shorting out.
Btw. Heard its difficult removing said relay.
Try a large pair of tweazers,bend the tips inward(set up on your new relay for sizing).
Slide tweazers over n beyond the lock tabs to release n pull relay out.
Slightly easier than the tale of p.brake removal!!
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top