Honda Ridgeline Owners Club Forums banner

1 - 13 of 13 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
We just bought a Honda Ridgeline. It's a 2006 with about 150k miles. It runs well however I bought it with the VSA and triangle exclamation point light on. I have checked the tire pressures and they are good.

I hooked it up to my OBD tool (I have an Autel Maxilink ML619 not a honda scanner) and it gave me the following codes.
91-1 CAN Communication failure.
27-1 Steering Angle Sensor Failure
72-1 Steering Angle Sensor Failure

I reset the codes and took it for a drive. Only 27-1 Steering Angle Sensor Failure came back.

So I'm assuming the SAS is at fault? I have read other posts where people have read the angle of the sensor and somehow reset it back to 0 and other posts where people have gotten the sensor replaced and that fixed the issue.

Where can you buy the sensor? I've looked online and called my local honda dealer and neither turned up anything. The honda dealer simply said that I could purchase the entire steering column and it may or may not come with the sensor.
 

·
Registered
Joined
·
45 Posts
im in the same boat as you, mine is a 10 with 85k km, the vsa and ! lights come on intermittently. the dealer cleared it before the purchase, but it comes and goes. I'll have to run my reader on it and see what comes back too. Also read that it can possibly a bad battery? The alternator on mine was replaced as part of the reconditioning service, so the battery may be weak now.
 

·
Registered
Joined
·
45 Posts
brought it back to the shop today, ran the battery test again and it passed. The battery looked fresh, but they couldnt pull up when it was done. It is a OEM branded battery. This time when they scanned the codes, it showed a steering angle sensor failure. Tech said he reset the angle to zero and cleared the code. Drove around for a day and it vsa light popped back up again. So back in the shop on monday for a more thorough look.

Shop pulled the steering sensor today and confirmed that it had failed. It was working intermittently, which is why the VSA light was coming on and off.

Quoted $250 for the sensor and a 0.8hr install. Fortunately for me they will be taking care of it as part of my purchase.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #6
Shop pulled the steering sensor today and confirmed that it had failed. It was working intermittently, which is why the VSA light was coming on and off.

Quoted $250 for the sensor and a 0.8hr install. Fortunately for me they will be taking care of it as part of my purchase.
Could you help me out with the part number for the part? The honda dealer has not been able to provide me with the part and I cannot find it online either.
 

·
Super Moderator
2008 Ridgeline RTS in Billet Silver Metallic
Joined
·
22,579 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #11
so this is the part that was replaced: 35251-SJC-A12

https://www.hondapartsnow.com/genuine/honda~body~switch~35251-sjc-a12.html

I guess the steering angle sensor is in the combination switch. all good now, no vsa or ! light since......but then this morning the vtm-4 light came ugh
Thank you very much for that part number! I'm gonna try to see if I can somehow set the steering wheel straight (I don't know if it was ever taken off and put back on wrong) but if not then I'll just replace the part.
 

·
Registered
Joined
·
45 Posts
You can definitely try that out first, wouldnt hurt I guess! The tech told me that the sensor contacts were failing intermittently, so thats why the lights went on and off for me.
 

·
Super Moderator
2008 Ridgeline RTS in Billet Silver Metallic
Joined
·
22,579 Posts
  • Like
Reactions: Carsmak
1 - 13 of 13 Posts
Top